Silk Test

機能テスト自動化ツール

評価版お申し込みページへ   見積り依頼ページへ   テストツール・ソリューション関連のイベント・セミナーへ

システム要件

ハードウェア(推奨)

プロセッサ
・ IntelもしくはAMD Dual-Coreプロセッサ 2GHz以上

RAM 
・ 4GBの空きメモリ

ハードディスクの空き容量
・ 4GB以上の空きディスク容量

※自作機(ベアボーンキット、ショップブランド機を含む)は動作保証外証外です。

ソフトウェア要件

Silk Test をインストールして実行するには、次のソフトウェアがインストールされている必要があります。
・.NET Framework4.7以降 (フルセットアップ)
・Windows Update 3118401(Windowsでの汎用のCランタイム)

OS

Microsoft Windows 7 SP1
Microsoft Windows 8 (Windows ストア アプリ以外)
Microsoft Windows 8.1 (Windows ストア アプリ以外)
Microsoft Windows 10
Microsoft Windows Server 2008 R2
Microsoft Windows Server 2012
Microsoft Windows Server 2012 R2
Microsoft Windows Server 2016
Microsoft Windows Server 2019

データベース

Silk Testでは、Silk Test Workbench の資産の格納について、以下のデータベースがサポートされています。
オペレーティングシステムについては、マイクロソフトのSQL Server対応プラットフォームに準じます。
Oracle 11は、AL32UTF8(Oracle標準)ではなく、UTF8(Unicode 3.0)の文字コードで作成する必要があります。
・Microsoft SQL Server 2017
・Microsoft SQL Server 2016
・Microsoft SQL Server 2014
・Microsoft SQL Server 2012 SP1
・Microsoft SQL Server 2012
・Microsoft SQL Server 2008 (SP2) + Express
・Oracle 12.1 (AL32UTF8をサポート)
・Oracle 11.2
・Oracle 11.1
・Microsoft Access 2000 (製品評価用)
※Micro Focusは、Microsoft SQL Server を使用することを推奨します。
※Oracle 11 ODBC ドライバは、パッチレベル 4 (11.2.0.4) 以降が必要です。

開発環境への統合

Silk4Net
・Visual Studio 2012 Professional Edition
・Visual Studio 2013/2015/2017/2019 Community Edition 以上
Silk4J
・Eclipse 4.4.2以降では、32ビットおよび64ビットの両方でSilk4Jを統合できます。Silk Testには、バージョン4.11が付属しています。
※Silk4J をインストールするシステムに Java 8 以降が必要です。

サポート環境

  Silk Test Premium Edition
Silk Test Standard Edition
Webアプリケーション
■PCのWebブラウザ
・Internet Explorer 8、9、10、11
・Firefox 60(ESR)、61、62、63、64、65、66
・Chrome 65、66、67、68、69、70、71、72、73、74
・Microsoft Edge Windows 10 Anniversary Update (38.14393)、Windows 10 Creators Update (40.15063)、Windows 10 Fall Creators Update (41.16299)、Windows 10 April 2018 Update (42.17134)、Windows 10 October 2018 Update (44.17763)
・Mac上のApple Safari 9, 10.1, 11, 12

■モバイルブラウザ
Android 4.4、5.x、6.x、7.x、8.x 環境の以下のブラウザをサポート
・Chrome for Android
・AOSPブラウザ
※国内のAndroidデバイスに用意されているAOSPブラウザは独自の改変が多く見受けられます。事前に十分な動作確認をお願いします。
iOS 9.3、10.x、11.x 、12.x環境の以下のブラウザをサポート(iOS Safari の再生には XCode 9.x、XCode 10.x が必要です)
・iOSのApple Safari 9, 10.1, 11, 12
※Mac Safariの記録/再生にはApple社のMac(OSX El Capitan、OSX Sierra もしくは HighSierra) が必要です。
※Silk Testからの記録/再生は全てMac OSを経由して行われますので、Mac上にデバイスラボ構築用専用プログラムをインストールし、iOSデバイスを常時接続しておく必要があります。

■Apache Flex
・Apache Flex バージョン3.5 ~4.14.1、および Adobe AIR 2.0 以降 (Apache Flex 4.x でビルド)
※Adobe Flash Player 10 以降をサポート。ブラウザは Internet Explorer に限られます。

■Silverlight
・Silverlight 3 (Silverlight Runtime 4), 4 (Silverlight Runtime 4および Silverlight Runtime 5)

■Java アプレット
・Internet Explorer上で実行するWebアプリケーションでのアプレットをサポート

■HTML5

■Oracle Forms 10g および 11g(Internet Explorer 用)
■ERP
・SAP GUI クライアント 7.10
・SAP GUI クライアント 7.20
・SAP GUI クライアント 7.30
・SAP GUI クライアント 7.40
・SAP GUI クライアント 7.50
デスクトップアプリケーション
■ネイティブGUI
・Win 32/64標準

■.NET GUI
・WinForms .NET 3.0、3.5、3.5 SP1、4.0、4.5、4.6、4.7
・WPF .NET 3.5 SP1、4.0、4.5、4.6、4.7

■ユニバーサルWindowsプラットフォームアプリケーション
・Microsoft Windows 10
・Microsoft Windows Server 2019

■Rumba
・8.1、8.2、8.3、9.0、9.1、9.2、9.3、9.4、9.5

■Java (32bit/64bit)
・Java AWT/Swing Java 6、Java 7、Java 8、Java 9、Java 10、Java 11、Java 12
・Java SWT 3.2以降
 
Silk Test Mobile Edition
ネイティブデバイスアプリケーション
・Android 4.4、5.x、6.x、7.x、8.x、9.x のアプリケーション
・Chrome for Android
・AOSPブラウザ
※※国内のAndroidデバイスに用意されているAOSPブラウザは独自の改変が多く見受けられます。
事前に十分な動作確認をお願いします。

・iOS 9.3、10.x、11.x、12.x のアプリケーション
・iOSのApple Safari
※Silk Testからの記録/再生は全てMac OSを経由して行われますので、OS X Sierra がインストールされた Mac 上にデバイスラボ構築用専用プログラムをインストールし、iOSデバイスを常時接続しておく必要があります。
※ネイティブモバイルアプリ/モバイルSafariのテストにはApple Developer Programの参加と開発統合環境である XCode8.3、XCode9.x、XCode10.xが必要となります。
評価版お申し込みページへ   見積り依頼ページへ   テストツール・ソリューション関連のイベント・セミナーへ

TOP

-----