システム要件【Silk Test

SCROLL DOWN

システム要件

ハードウェア(推奨)

プロセッサ

  • IntelもしくはAMD Dual-Coreプロセッサ 2GHz以上

RAM

  • 4GBの空きメモリ

ハードディスクの空き容量

  • 4GB以上の空きディスク容量

※自作機(ベアボーンキット、ショップブランド機を含む)は動作保証外です。

ソフトウェア要件

Silk Test をインストールして実行するには、次のソフトウェアがインストールされている必要があります。

  • .NET Framework4.7以降 (フルセットアップ)
  • Windows Update 3118401(Windowsでの汎用のCランタイム)

OS

  • Microsoft Windows 8.1 (Windows ストア アプリ以外)

  • Microsoft Windows 10

  • Microsoft Windows Server 2012

  • Microsoft Windows Server 2012 R2

  • Microsoft Windows Server 2016

  • Microsoft Windows Server 2019

データベース

Silk Testでは、Silk Test Workbench の資産の格納について、以下のデータベースがサポートされています。
オペレーティングシステムについては、マイクロソフトのSQL Server対応プラットフォームに準じます。
Oracle11は、AL32UTF8(Oracle標準)ではなく、UTF8(Unicode3.0)の文字コードで作成する必要があります。

  • Microsoft SQL Server 2017

  • Microsoft SQL Server 2016

  • Microsoft SQL Server 2014

  • Microsoft SQL Server 2012 SP1

  • Microsoft SQL Server 2012

  • Microsoft SQL Server 2008 (SP2) + Express

  • Oracle12.1 (AL32UTF8をサポート)

  • Oracle11.2

  • Oracle11.1

  • MS Access 2000 (製品評価用)

※Micro Focusは、Microsoft SQL Server を使用することを推奨します。

※Oracle11 ODBC ドライバは、パッチレベル 4 (11.2.0.4) 以降が必要です。

開発環境への統合

Silk4Net

  • Visual Studio 2012 Professional Edition

  • Visual Studio 2013/2015/2017/2019 Community Edition 以上

Silk4J

  • Eclipse 4.4.2以降では、32ビットおよび64ビットの両方でSilk4Jを統合できます。Silk Testには、バージョン4.9が付属しています。

※Silk4J をインストールするシステムに Java 8 以降が必要です。

動作確認済みのサポート環境

Silk Test Premium Edition
Silk Test Standard Edition  
Webアプリケーション
  • Mozilla Firefox 67, 68(ESR), 69, 70

  • Google Chrome 75, 76, 77, 78

  • Chrome for Android

  • Original Stock Android Brawser(AOSP)

  • iOS上のApple Safari 9, 10.1, 11, 12, 13

  • Mac上のApple Safari 9, 10.1, 11, 12, 13

  • MacOS(SafariまたはiOSのテストに使用) 10.12.6, 10.13, 10.14, 10.15

  • Internet Explorer 10, 11

  • Microsoft Edge Windows 10 October 2018 Update (44.17763), Windows 10 May 2019 Update (44.18362)

  • Android 5.x, 6.x, 7.x, 8.x, 9.x, 10.x

  • iOS 11.x, 12.x, 13.x

  • Xcode 10.x, 11.x

  • Silverlight 3 (Silverlight Runtime 4), 4 (Silverlight Runtime 4および Silverlight Runtime 5)

  • Apache Flex Apache Flex バージョン3.5 ~4.14.1、および Adobe AIR 2.0 以降 (Apache Flex 4.x でビルド) 、Adobe Flash Player 10 以降をサポート

  • Java アプレット Internet Explorer上で実行するWebアプリケーションでのアプレットをサポート

  • HTML5

  • Oracle Forms 10g および 11g(Internet Explorer 用)

ERP

  • SAP GUI クライアント 7.10

  • SAP GUI クライアント 7.20

  • SAP GUI クライアント 7.30

  • SAP GUI クライアント 7.40

  • SAP GUI クライアント 7.50

デスクトップアプリケーション
Java AWT/Swing (Java Foundation Classesを含む)
  • Java 6、Java 7、Java 8、Java 11、Java 13

Java SWT
  • Java 6、Java 7、Java 8、Java 11、Java 13

  • Java SWT バージョン3.2以降

Java FX
  • Windows 8以降

Rumba
  • 8.1、8.2、8.3、9.0、9.1、9.2、9.3、9.4、9.5

MFC
  • 14.11

Visual COBOL
Win32
WinForms
  • .NET 3.5 SP1、4.0、4.5、4.6、4.7、4.8

WPF
  • .NET 3.5 SP1、4.0、4.5、4.6、4.7、4.8

Silk Test Mobile Edition
ネイティブデバイスアプリケーション
  • MacOS(SafariまたはiOSのテストに使用) 10.12.6, 10.13, 10.14, 10.15

  • Android 5.x, 6.x, 7.x, 8.x, 9.x, 10.x

  • iOS 10.x, 11.x, 12.x, 13.x

※ネイティブモバイルアプリ/モバイルSafariのテストにはApple Developer Programの参加と開発統合環境である Xcode10.x、Xcode11.xが必要となります。